dotConnect for Oracle Documentation
NuGet Packages
support@devart.com

dotConnect for Oracle has three sets of assemblies: for full .NET Framework, .NET Standard 1.3 compatible assemblies, and .NET Standard 2.0 compatible assemblies. The .NET Standard 1.3 compatible assemblies are compatible with .NET Core 1.0 and higher and .NET Framework 4.6 and higher. The .NET Standard 2.0 compatible assemblies are compatible with .NET Core 2.0 and higher and .NET Framework 4.6.1 and higher. .NET Standard compatible assemblies are only available as NuGet packages.

The dotConnect for Oracle NuGet packages are added to your project from nuget.org as usual, via the Package Manager Console. The dotConnect for Oracle NuGet packages contain both .NET Standard 1.3 and .NET Standard 2.0 compatible assemblies. The corresponding assemblies are selected automatically, depending on the target framework of your project.

For projects, using general ADO.NET functionality of dotConnect for Oracle, you need to install the Devart.Data.Oracle package. Execute the following command in the Package Manager Console:

Install-Package Devart.Data.Oracle

For projects, using LinqConnect features of dotConnect for Oracle, you need to install the Devart.Data.Oracle.Linq package. Execute the following command in the Package Manager Console:

Install-Package Devart.Data.Oracle.Linq

For projects, using Entity Framework Core, you need to install the Devart.Data.Oracle.EFCore package. Execute the following command in the Package Manager Console:

Install-Package Devart.Data.Oracle.EFCore

For projects, using Entity Framework Core 1.1, for which you use database-first approach and generate an Entity Framework Core mapping via the Scaffold-DbContext command of Package Manager Console, you need to install the Devart.Data.Oracle.EFCore.Design package. Execute the following command in the Package Manager Console:

Install-Package Devart.Data.Oracle.EFCore.Design

Note that this package is not needed any more for Entity Framework Core 2.0. All the needed functionality Entity Framework Core 2.0 is included to the Devart.Data.Oracle.EFCore package.

See Also

.NET Standard Compatibility