PgDAC

Compatibility

PostgreSQL Compatibility

PgDAC supports PostgreSQL server versions from 8.0 to 13.

Microsoft Azure Database for PostgreSQL Compatibility

PgDAC supports Microsoft Azure Database for PostgreSQL.

Amazon RDS for PostgreSQL Compatibility

PgDAC supports Amazon RDS for PostgreSQL and Amazon Aurora.

Google Cloud for PostgreSQL Compatibility

PgDAC supports Google Cloud for PostgreSQL.

IDE Compatibility

PgDAC is compatible with the following IDEs:

All the existing Delphi and C++Builder editions are supported: Architect, Enterprise, Professional, Community, and Starter.

Lazarus and Free Pascal are supported only in Trial Edition and Professional Edition with source code.

Supported Target Platforms

Support for Windows 64-bit is available since RAD Studio XE2. Support for iOS 64-bit is available since RAD Studio XE8. Support for Android 32-bit is available since RAD Studio XE5. Support for Linux 64-bit is available since RAD Studio 10.2 Tokyo. Support for macOS 64-bit is available since RAD Studio 10.3 Rio. Support for Android 64-bit is available since RAD Studio 10.3.3 Rio.

Supported GUI Frameworks

Devart Data Access Components Compatibility

All DAC products are compatible with each other.

But, to install several DAC products to the same IDE, it is necessary to make sure that all DAC products have the same common engine (BPL files) version. The latest versions of DAC products or versions with the same release date always have the same version of the common engine and can be installed to the same IDE.

© 1997-2021 Devart. All Rights Reserved. Request Support DAC Forum Provide Feedback