dotConnect for SugarCRM Compatibility

Framework Compatibility

The provider works with .NET Frameworks 4.0, 4.5, and 4.6. The provider runtime assemblies can be used in applications for .NET Framework 3.5, but no design-time is available for .NET Framework 3.5. The product is compatible with ADO.NET Entity Framework v4 - v6 and Entity Framework Core.

IDE Compatibility

dotConnect for SugarCRM and can be used with the following development environments:

  • Microsoft Visual Studio 2015
  • Microsoft Visual Studio 2013
  • Microsoft Visual Studio 2012
  • Microsoft Visual Studio 2010

 

Microsoft Visual Studio Industry Program

 


There are some limitations in Express Editions of Visual Studio. The following features are not available: provider add-in, automatic toolbox components registration and DDEX integration. As an exclusion, Visual Web Developer 2010 supports DDEX features.

Devart Data Providers Compatibility

Since Devart data providers use a common assembly (Devart.Data.dll), it is necessary to make sure that all installed data providers are compatible.