EntityDAC Compatibility

IDE Compatibility

EntityDAC is compatible with the following IDEs:

  • Embarcadero RAD Studio 10.4 Sydney
    • Embarcadero Delphi 10.4 Sydney for Windows
    • Embarcadero Delphi 10.4 Sydney for macOS
    • Embarcadero Delphi 10.4 Sydney for Linux
    • Embarcadero Delphi 10.4 Sydney for iOS
    • Embarcadero Delphi 10.4 Sydney for Android
  • Embarcadero RAD Studio 10.3 Rio (Requires Release 2 or Release 3)
    • Embarcadero Delphi 10.3 Rio for Windows
    • Embarcadero Delphi 10.3 Rio for macOS
    • Embarcadero Delphi 10.3 Rio for Linux
    • Embarcadero Delphi 10.3 Rio for iOS
    • Embarcadero Delphi 10.3 Rio for Android
  • Embarcadero RAD Studio 10.2 Tokyo
    • Embarcadero Delphi 10.2 Tokyo for Windows
    • Embarcadero Delphi 10.2 Tokyo for macOS
    • Embarcadero Delphi 10.2 Tokyo for Linux
    • Embarcadero Delphi 10.2 Tokyo for iOS
    • Embarcadero Delphi 10.2 Tokyo for Android
  • Embarcadero RAD Studio 10.1 Berlin
    • Embarcadero Delphi 10.1 Berlin for Windows
    • Embarcadero Delphi 10.1 Berlin for macOS
    • Embarcadero Delphi 10.1 Berlin for iOS
    • Embarcadero Delphi 10.1 Berlin for Android
  • Embarcadero RAD Studio 10 Seattle
    • Embarcadero Delphi 10 Seattle for Windows
    • Embarcadero Delphi 10 Seattle for macOS
    • Embarcadero Delphi 10 Seattle for iOS
    • Embarcadero Delphi 10 Seattle for Android
  • Embarcadero RAD Studio XE8
    • Embarcadero Delphi XE8 for Windows
    • Embarcadero Delphi XE8 for macOS
    • Embarcadero Delphi XE8 for iOS
    • Embarcadero Delphi XE8 for Android
  • Embarcadero RAD Studio XE7
    • Embarcadero Delphi XE7 for Windows
    • Embarcadero Delphi XE7 for macOS
    • Embarcadero Delphi XE7 for iOS
    • Embarcadero Delphi XE7 for Android
  • Embarcadero RAD Studio XE6
    • Embarcadero Delphi XE6 for Windows
    • Embarcadero Delphi XE6 for macOS
    • Embarcadero Delphi XE6 for iOS
    • Embarcadero Delphi XE6 for Android
  • Embarcadero RAD Studio XE5 (Requires Update 2)
    • Embarcadero Delphi XE5 for Windows
    • Embarcadero Delphi XE5 for macOS
    • Embarcadero Delphi XE5 for iOS
    • Embarcadero Delphi XE5 for Android
  • Embarcadero RAD Studio XE4
    • Embarcadero Delphi XE4 for Windows
    • Embarcadero Delphi XE4 for macOS
    • Embarcadero Delphi XE4 for iOS
  • Embarcadero RAD Studio XE3 (Requires Update 2 )
    • Embarcadero Delphi XE3 for Windows
    • Embarcadero Delphi XE3 for macOS
  • Embarcadero RAD Studio XE2 (Requires Update 4 Hotfix 1 )
    • Embarcadero Delphi XE2 for Windows
    • Embarcadero Delphi XE2 for macOS
  • Embarcadero RAD Studio XE
    • Embarcadero Delphi XE
  • Embarcadero RAD Studio 2010
    • Embarcadero Delphi 2010
  • CodeGear RAD Studio 2009 (Requires Update 3 )
    • CodeGear Delphi 2009
  • CodeGear RAD Studio 2007
    • CodeGear Delphi 2007

All existing Delphi editions are supported: Architect, Enterprise, Professional, Community, and Starter.

Supported Target Platforms

  • Windows, 32-bit and 64-bit
  • macOS, 32-bit and 64-bit
  • Linux, 64-bit
  • iOS, 32-bit and 64-bit
  • Android, 32-bit and 64-bit

Note that support for Windows 64-bit and macOS 32-bit is available since RAD Studio XE2. Support for iOS 32-bit is available since RAD Studio XE4. Support for iOS 64-bit is available since RAD Studio XE8. Support for Android 32-bit is available since RAD Studio XE5. Support for Linux 64-bit is available since RAD Studio 10.2 Tokyo. Support for macOS 64-bit is available since RAD Studio 10.3 Rio. Support for Android 64-bit is available since RAD Studio 10.3.3 Rio. Support for macOS 32-bit and iOS 32-bit was removed in RAD Studio 10.4.

Supported GUI Frameworks

  • FireMonkey (FMX)
  • Visual Component Library (VCL)

Devart Data Access Components Compatibility

Standard Data Access Components Compatibility

EntityDAC supports the following standard data access components:

  • ADO
  • IBX
  • dbExpress
  • FireDAC

Third-Party Data Access Components Compatibility

EntityDAC also supports various 3rd-party data access components:

  • BDE
  • DOA
  • FIbPlus
  • NexusDB
  • Zeos

Entity Developer Database Compatibility

  • SQL Server 2000 and higher
  • MySQL 4.1 and higher
  • Oracle 9 and higher
  • PostgreSQL 8 and higher
  • SQLite 3 and higher
  • Firebird 2 and higher
  • DB2 9.5 and higher

Entity Developer Providers Compatibility

Entity Developer supports the following ADO.NET providers: