Compatibility

Database Providers Support

Entity Developer supports the following ADO.NET providers:

* Not supported by Telerik Data Access.

For LINQ to SQL models Entity Developer supports only SqlClient to connect to SQL Server database.

ORM Framework Compatibility

  • Entity Framework v1 - v6
  • Entity Framework Core
  • NHibernate 3 and higher
  • Telerik Data Access (current version)
  • LINQ to SQL
  • LinqConnect
  • EntityDAC

Database Support

  • SQL Server 2000 and higher
  • MySQL 4.1 and higher
  • Oracle 9 and higher
  • PostgreSQL 8 and higher
  • SQLite 3 and higher
  • Firebird 2 and higher
  • DB2 9.5 and higher

IDE Compatibility

Entity Developer integrates with Visual Studio 2008, 2010, 2012, 2013, 2015, and 2017.

.NET Framework 3.5 Service Pack 1 or higher is required for Entity Developer.